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Kata Pengantar

Puji syukur kami panjatkan ke hadirat Tuhan Yang Maha Esa, atas segala
nikmat dan karunia-Nya, sehingga kami dapat melaksanakan kegiatan pengabdian
kepada masyarakat yang berwujud sebagai narasumber pada Madrasan Aliyah Al-
Asror Gunung Pati Semarang — Pelatihan untuk Guru “Implementasi Multimedia
Pembelajaran Kurikulum 2013 Berbasis Adobe Flash”, diselenggarakan pada tanggal
16-20 Mei 2014, di Ruang Kelas Madrasan Aliyah Al-Asror Gunung Pati Semarang.
Dari pelatihan ini diharapkan dapat membantu Guru dalam meningkatkat prestasi
siswa dengan bantuan multimedia pembelajaran dalam proses belajar mengajar.
pengembang IT dengan format multimedia pembelajaran, dapat memegang
memegang peranan penting sebagai sarana belajar mengajar yang efektif dan
menyenangkan.

Kami menyadari pada laporan ini masih banyak kekurangan, karena itu tidak

lupa kami menyampaikan maaf sebesar-besarnya.

Semarang, Mei 2014

Fikri Budiman
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1. Latar Belakang

Pemanfaatan multimedia sebagai sarana media tambahan belajar
mengajar sangat diperlukan pada era digital seperti saat ini. Multimedia adalah
penggabungan beberapa buah media yang berlainan dalam sebuah produk
multimedia. Pada pelatihan ini dapat memberi pengenalan tentang berbagai jenis
media (teks, gambar, animasi, audio, video dan interaktivity), dan bagaimana
multimedia tersebut dapat dimanfaatkan untuk media pembelajaran yang dapat
menyajikan materi pembelajaran menjadi lebih mudah dipahami dan
menyenangkan. Pemanfaatan multimedia dalam bidang pendidikan adalah
sebagai media pembelajaran yang dapat menyampaikan bahan pengajaran secara
interaktif dan dapat mempermudah pembelajaran karena dididukung oleh
berbagai aspek: suara, video, animasi, teks, dan grafik.

Pelatihan “Implementasi Multimedia Pembelajaran Kurikulum 2013
Berbasis Adobe Flash” ditujukan untuk guru-guru pada Madrasan Aliyah Al-
Asror Gunung Pati Semarang. Pelatihan ini diharapkan dapat membantu para
guru dalam menyampaikan materi di dalam kelas dengan alat bantu komputer dan
proyektor. Dengan adanya media pembelajaran, penyampaian materi akan dapat

lebih menyenangkan dan efektif.

2. Kegiatan
Nama . Pelatihan untuk Guru “Implementasi Multimedia Pem-
belajaran Kurikulum 2013 Berbasis Adobe Flash”,
Peserta . Guru / Staf Pengajar
Tanggal . 16-20 Mei 2014
Jam : 08.00 - selesai
Tempat : Ruang Kelas

Madrasan Aliyah Al-Asror Gunung Pati Semarang



3. Tujuan
- Untuk memberi informasi bagaimana cara merancang multimedia

pembelajaran dengan mengkombinasikan gambar, teks, animasi, dan
suara.

- Dpata praktek secara langsung pembuatan multimedia pembelajaran
sesuai dengan mata pelajaran yang diampu berdasarkan kurikulum 2013.

4. Pelaksanaan Kegiatan
a. Surat Tugas dan Sertifikat Instruktur
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LEMBAGA PENELITIAN DAN PENGABDIAN KEPADA MASYARAKAT (LP2M) ':‘3
UNIVERSITAS DIAN NUSWANTORO .8

%A\u“c’

SURAT TUGAS
No. 104/A.3804UDN-D1/V2014
Dircktur Lembaga Perclitin dan  Pengabdian Masyarnkat Universitas  Dian  Nuswantoro

Scmarang memberikan tugas kepada :
No NPP_
1 mmm 0686.11.1995.070
2 | Karis Widyatmoke, $.Si., M.Kom 0686.11.1998.159
3__| Sugiyanio, M.Kom 0686.11.1999.182
4 | Ahmad Zainul Fanani, M.Kom 0636.11.1996.101
5| Muslih MKom 0686.11.1996 082

Untuk melakukan pengsbdian kcpada masyarakat, "Implcmentasi Mulumedia Pembclajaran
WMNIJBMAMGM'M(TIHHP&

Hari/Tgl. : 16-20 Mei 2014

Waktu : 08.00 WIB - selesai

Tempat : MMA.M(MA)AL-ASRO!
Gunung Pati Semarang

Lain-Lain :

Harp dilaksanakan dengan scbaik-baiknya dan penuh tanggung jawab.
Memberikan Inporan kepada Kepala Pusat Pengabdian kepada Masyarakat setclah
melaksanakan tugas.

16 Mei 2014

Kantor : JL Nakuia | No. 5 - 11, Semarang 50131 indonesis  Telp. (024) 3517281, 3520165 Fax. (024) 3580684
Home Page : Mip/www dinus acid  Emall - selostariai@odinus ac it
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c. Absensi Peserta (16-17 dan 19-20 Mei 2014)
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DAFTAR HADIR GURU DAN KARYAWAN MA AL ASROR SEMARANG
DALAM BINTEK PEMBUATAN MEDIA PEMBELAJARAN
YANG DISELENGGARAKAN OLEH UNIVERSITAS DIAN NUSWANTORO SEMARANG
Pertemuan Ke- 31
Hari/ Tanggal : Jum'at, 16 Mei 2014
Pukul : 13.00 - 16.00 WIB
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|Hanik Khaeratun Nisak, S.Pd
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DAFTAR HADIR GURU DAN KARYAWAN MA AL ASROR SEMARANG
DALAM BINTEK PEMBUATAN MEDIA PEMBELAJARAN
YANG DISELENGGARAKAN OLEH UNIVERSITAS DIAN NUSWANTORO SEMARANG

Pertemuan Ke- 12
Hari/ Tanggal :Sabtu, 17 Mei 2014
Pukul : 13.00 - 16.00 WIB
No. Nama Tanda Tangan Keterangan
5
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DAFTAR HADIR GURU DAN KARYAWAN MA AL ASROR SEMARANG
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DAFTAR HADIR GURU DAN KARYAWAN MA AL ASROR SEMARANG
DALAM BINTEK PEMBUATAN MEDIA PEMBELAJARAN
YANG DISELENGGARAKAN OLEH UNIVERSITAS DIAN NUSWANTORO SEMARANG
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MODUL PELATIHAN

MEDIA PEMBELAJARAN MULTIMEDIA
MENGGUNAKAN ADOBE FLASH
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UNIVERSITAS DIAN NUSWANTORO SEMARANG
dan
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Fikri Budiman, M.Kom
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Muslih, M.Kom
Karis Widyatmoko, S.Si, M.Kom

A. Zaenul Fanani, S.Si, M.Kom



BAB |
INTERFACE ADOBE FLASH

1. Pengenalan Adobe Flash
Adobe Flash merupakan standar profesional yang digunakan untuk membuat
web lebih hidup dengan permainan animasi dan sinkronisasi suara yang
mengagumkan. Bayangkan pada halaman web, anda dapat membuat animasi atau
promosi suatu produk seperti iklan di layar televisi. Merancang menu navigasi seperti
menu navigasi pada game interaktif agar pengunjung tidak merasa bosan berada
dalam situs anda.
2. Konsep Dasar Dan Istilah
a. Flash Stage.
Flash Stage dalam kenyataan seperti layar bioskop. Pada flash stage berupa
kotak putih besar. Semua obyek seperti gambar, tulisan, dan foto ditempat pada
stage. Di luar area kotak putih, tersebut merupakan daerah berwarna abu-abu. Di
area ini penonton tidak dapat melihat objek apapun saat film sedang dimainkan.
Perhatikan gambar dibawah. layar Flash dibawabh ini :

W ADT ww Bt PONY M LU LM et W D

a0l * U ® D 3 X M K B W WO &N WM N % w0 s s -
LR Ze0y n ” - '....4-
u¢ Timeline Dw ey
5. T
, o, : P %
Zlanua L owE Ml L At O 4 97 :
Ll T .,....‘I & & ' R panpes
= ] - o
s« | Tools
/= - Status
.:..‘ X bar
i o
rl
“m
Stage R
S
: .'I.
: A ™ ¥ eaauA
[ e i o) ek ] e Tha _
1 et wea [ ames M 3 ACKNCEL LA Mt Defak
Conmrt dow P °
a

Ukuran default dari stage adalah 550 picxel dan tinggi 400 picxel (picture
elment).Picxel merupakan titik terkecil pada layar monitor Anda. Untuk
mengubah ukuran sesuai kebutuhan : Klik menu Modify > Document, muncul
dialog box Document Properties seperti pada gambar di bawah, Anda tinggal
mengubah sesuai kebutuhannya.

1|Modul Pelatihan Pembuatan Object Learning Flash



Title: |

Descripkion:

Dimensions: | Sk (width) = {height)

Match: () Printer Contents (%) Default

Backaround calor: -

Frame rate: fp=

Ruler units: | Pixels L |

o 1 [

b. Toolbox
Toolbox berisi alat kerja berupa berbagai simbol gambar atau icon yang

masing-masing mempunyai fungsi tertentu dan paling sering digunakan. Adapun
komponen-komponen toolbox adalah sebagai berikut :

Pl
2 ]

LB

n
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1) Arrow, digunakan untuk memilih objek. Dengan 1 kali klik berarti sebuah
objek telah dipilih, dengan klik ganda (dua kali) berarti Anda memilih objek
dan seluruh komponen yang dimilikinya. Dengan mendrag Arrow tool Anda
dapat membuat sebuah area persegi yang akan mengaktifkan pemilihan atas
semua yang ada di dalamnya.

2) Line, merupakan alat untuk membuat garis. Bila Anda membuat garis sambiil
menekan tombol Shift, maka akan terbentuk garis yang horisontal, vertikal
atau miring 45o.

3) Pen, digunakan untuk membuat objek elips (oval). Untuk membuat lingkaran
gunakan tool ini sambil menekan Shift.

4) Pencil, Adalah alat untuk menggambar garis atau titik secara bebas.

5) Free Transform, digunakan untuk memodifikasi bentuk dari suatu objek.

6) Ink Bottle, digunakan untuk mewarnai suatu garis.

7) Eyedropper, digunakan untuk mengambil warna yang berasal dari suatu objek
di stagge sehingga Anda bisa menyamakan warna ketika menggambar.

8) Hand, digunakan untuk menggeser stage secara bebas, sanggat berguna bila
Anda memperbesar (zoom) stage sehinga tidak seluruh stage terlihat dilayar.

9) Stroke Color, digunakan untuk memiliih warna ketika mengambar garis.

10) Fill Color, digunakan untuk mengisi warna dari bagian dalam objek yang
sedang digambar. Disini juga tersedia efek pengisian tergradasi.

11) Default Color, Klik ikon ini untuk mengembalikan stroke color menjadi hitam
dan fill coor menjadi putih.

12) No Color, digunakan untuk menghilangkan warna dari garis atau warna dari isi
objek tergantung penggunaannya.

13) Option Pane, menampilkan berbagai pilihan untuk memodifikasi efek dari
suatu tool yang kita pilih, berbeda untuk setiap tool.

14) Subselect, digunakan untuk memodifikasi suatu ggaris yang dibuat dengan Pen
tool.

15) Lasso, digunakan untuk memilih suatu area secara tidak teratur. Semua yang
masuk areanya akan terpilih.

16) Text, digunakan untuk membuat text box yang dapat diisi dengan berbagai
tulisan.

17) Rectangle, digunakan untuk membuat bentuk persegi. Bila ingin membuat
bujur sangkar secara sempurna gunakan tool ini sambil menekan tombol shift.

18) Brush, digunakan untuk menggambar dengan kuas secara bebas.

19) Fill Transform, digunakan untuk memodifikasi bentuk dan posisi dari
Gradient Fill.

20) Paint Bucket, digunakan untuk memodifikasi warna dan gradasi warna di
dalam suatu objek.

21) Eraser, digunakan untuk menghapus suatu gambar.

22) Zoom, merupakan kaca pembesar untuk memperbesar gambar, tetapi juga
dapat berfungsi sebaliknya, yaitu untuk memperkecil gambar.

23) Swap Color, digunakan untuk membalik warna garis atau isi suatu objek.

3|Modul Pelatihan Pembuatan Object Learning Flash



c. Layer Area
Layer adalah lapisan yang menutup permukaan stage. Stage biasanya terdiri
dari beberapa lapisan (layer) dimana dengan ini setiap objek dapat bergerak
sendirisendiri berdasarkan layer-masing-masing. Layer seperti lembaran kertas
tranparan yang berguna untuk membantu proses animasi dan penggambaran.
Layer tidak hanya untuk objek gambar saja, tetapi dapat berupa suara dan tulisan.

| Timeline | &5 Scene 1

& = Show All Layer
v & Folder 1 /

As Outline

Layer Names ) ERGRE I

Insert Layer

— i iat e Delete Layer

Lock / Unlock All Layers

Add Motion Guide

Show / Hide All Layers
Insert Layer Folde

Komponen-komponen layer adalah sebagai berikut :

1) Layer Name, menunjukkan nama dari setiap layer yang ada pada proyek.
Untuk mengubah nama layer, klik ganda sebuah layer name, dan namailah
setiap layer sesuai isi atau tujuannya bagi proyek tersebut.

2) Add a Layer, digunakan untuk menambahkan suatu layer dalam proyek.

3) Add a Motion Guide Layer, digunakan untuk menambah layer panduan yang
disebut Guide Layer. Layer ini berisi sebuah jalur yang digunakan untuk
memandu arah gerak sebuah objek. Jalur ini tidak akan nampak ketika movie
dijalankan.

4) Delete Layer, Bila ditekan akan menghapus sebuah layer yang dipilih beserta
semua objek yang terdapat didalamnya. Hati-hati menggunakannya.

5) Show or Hide Layer, digunakan untuk menampakan layer yang sedang
disembunyikan dan sebaliknya.

6) Lock or Unlock Layer, digunakan untuk mengunci atau membuka layer.

7) Show Layer as Outlines, menyebabkan semua objek yang terdapat pada suatu
layer akan ditampilkan dalam bentuk kerangka luarnya saja.

d. Timeline
Timeline adalah elemen yang dimiliki Flash untuk mengontrol semua
kejadian ketika movie dimainkan. Jadi, semua jalan cerita diatur disini, kapan
aktor ini harus muncul dan kapan menghilang atau kapan efek suatu harus ada dan

4|Modul Pelatihan Pembuatan Object Learning Flash



sebagainya. Sehingga Timeline mempunyai tugas mengatur waktu cerita dan
pemunculan objek-objek tertentu.

f [ 1204fs | 0gs ¢ »
Center T )
Elapsed time

Playhead Frame Time Line

l Niimher Menn |
ﬂ 1 }

5 10 15 20 25 30 35 40 4% 50 55 60 65 i

A

Onion skin Scrool bar
. . Frame rate
Onl_on sklr_w Current
Edit multiple ] )
Modify onion

1)

2)
3)

4)

5)

6)

7)

8)
9)

Komponen utama Timeline adalah :

Playhead, dengan melakukan drag terhadap Playhead menuju frame-frame
yang berlainan, Anda akan dapat melihat isi dari setiap frame, yang Anda
tuju. Bila Anda mengklik sebuah frame, maka secara otomatis Playhead akan
bergerak menuju frame yang Anda pilih.

Frame Number, merupakan pemandu Anda dalam bekerja dengan timeline.
Center Frame, digunakan untuk membantu menampilkan frame yang sedang
bekerja ke tengah-tengah daerah timeline yang terlihat, sangat berguna bila
Anda membuat movie dalam frame yang panjang mengingat timeline yang
terlalu panjang tidak akan ditampilkan seluruhnya dalam jendela.

Onion Skin View, merupakan fasilitas untuk menampilkan beberapa frame
sebelum dan atau sesudah frame yang kita pilih sekaligus. Frame-frame selain
frame yang kita pilih akan ditampilkan dalam nuansa yang lebih lembut dari
aslinya (bayang-bayang). Ini adalah fasilitas yang bagus untuk
memperhatikan urutan langkah animasi yang kita buat.

Onion Skin Outline View, mempunyai fungsi yang sama dengan Onion Skin
View, hanya saja gamabaran onjek yang ditampilkan pada tiap frame hanya
berupa kulit terluar dari objek itu.

Edit Multiple Frames, membantu Anda untuk memodifikasi beberapa frame
sekaligus.

Modify Onion Markers, menampilkan menu yang dapat dipilih untuk
menentukan seberapa banyak frame yang akan ditampilkan dalam mode
Onion Skin View.

Current Frame, menampilkan nomor frame yang sedang dipilih.

Frame Rate, menunjukkan berapa frame per detik yang akan ditampilkan
dalam Flash Movie Anda.

5|Modul Pelatihan Pembuatan Object Learning Flash



10) Playback Time, menunjukkan sudah berapa detik sebuah frame dijalankan.
11) Scroll Bars, melihat frame-frame yang tidak sanggup ditampilkan oleh
timeline yang tampak.

BAB Il
MENJALANKAN ADOBE FLASH

Untuk menjalankan Adobe Flash dapat melalui Start Menu dengan cara : Klik

Menu Start > Programs - Adobe Master Collection CS3 - Adobe Flash CS3,
selanjutnya akan ditampilkan layar utama Window Flash seperti yang ada pada gambar di

atas.

1.Menggambar Dan Mewarnai

Sebelum memulai menggambar perlu diketahui dulu alatnya. Flash
memberikan bermacam-macam alat (tool) untuk menggambar berbagai macam
bentuk seperti garis, lingkaran dan kotak. Dalam flash tools merupakan kumpulan
simbols gambar atau icon yang mempunyai fungsi tertentu dalam proses
penggambaran seperti gambar 1.3. di atas.

Fungsi-fungsi yang dapat dilakukan oleh tool tersebut disesuaikan dengan
gambar icon yang ada seperti untuk membuat garis berarti gunakan Line tool,
atau membuat lingkaran berarti gunakan Oval tool, dan sebagainya.

2.Membuat Tulisan

£ Properties  Filters | Parameters

6| M

Jika anda membuat tulisan di Flash, kita dapat mengubah ukuran, warna,
spasi dan perataannya, mirip seperti halnya kita sedang mengetik naskah pada
Word. Anda juga dapat memperlakukan tulisan sebagai objek yang dapati diputar,
diperbesar, atau diperkecil dan dimiringkan.

Mengenal Property Inspector Untuk Teks

Modifikasi atas properti teks dapat dilakukan sebelum atau setelah teks
tersebut selesai dibuat. Hal ini dapat dilakukan dengan berbagai cara, tetapi yang
termudah adalah dengan menggunakan Property Inspector yang muncul setelah
ikon Text tool dipilih.

S i

| Static Text vil A | Times New Roman v [12 |¢ BB 7 Eé% =EETE, 2)
Text Tool A [0 v 4t |Normal v | | Anti-alias for readability Vj
&) A3 [¥] auto kern

9 | Target:




Di dalam Property Inspector tersebut terdapat ikon-ikon yang berfungsi
untuk mengatur properti yang dimiliki oleh teks, yang dijalankan hanya dengan
menekan tombol kiri mouse pada ikon perintah yang dibutuhkan. Setelah itu akan
terjadi perubahan sesuai yang diinginkan.

4. Menulis Dengan Text Tool
Untuk membuat tulisan gunakan Text Tool :
1) Pilih menu File > New untuk memulai pekerjaan baru.

2) KIlik text tool A

3) Kursor berubah menjadi tanda “+” saat kita arahkan ke stage. Kemudian klik
pada stage dan kotak tulisan akan muncul.

4) Saat kita mengetik, flash otomatis memperlebar kotak tulisan tersebut sesuai
dengan panjang tulisan.

5) Block handle hanya dapat ditarik ke Kiri dan ke kanan untuk mengatur ukuran
kotak tempat tulisan kita.

PELATIHAN
MACROMEDIA FLASH ° Block handle
UNTUK GURU-GURU |

5. MENGEDIT DAN MENYELEKSI TULISAN
Pilih salah satu cara di bawah ini untuk masuk ke mode edit :
1) Kilik dua kali tulisan di stage dengan Arrow tool, atau
2) Kilik satu kali tulisan di stage dengan Text tool.
Setelah tulisan di stage masuk dalam mode edit yang berupa kotak dengan
block handle, Anda dapat menyeleksi dengan cara menyoroti tulisan dengan
mouse.

6. TRANSFORMING TEXT
Tulisan di Flash dianggap sebagai objek yang dapat diputar, diperbesar dan
diperkecil atau dimiringkan tetapi tetap kita dapat mengetik tulisan tersebut untuk
mengeditnya.
Untuk mentranform tulisan :
1) KIlik tulisan yang ada di stage.

2) Contoh bila ingin memutar tulisan, klik toolbar Free Tranform = . Akan
muncul titik-titik transform yang dapat diputar.

N
= 2
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3) KIlik Rotate and Skew Modifier, Klik dan drag salah satu handle di sudut
kotak untuk memutar teks.

4) Lepaskan pointer di garis kotak teks (diantara kotak pegangan) dan kemudian
drag untuk memiringkan teks.

5) Drag salah satu handle di salah satu sudut kotak teks untuk memperbesar atau
memperkecil ukuran teks.

PELATIHAN
MACROMEDBIA FLASH
UNTUK GURU-GURU

6) Untuk memperendah atau mempertinggi teks drag salah satu kotak pegangan
di bawah atau di atas kotak teks.

7) Untuk memanjangkan atau memperpendek teks, drag salah satu kotak
pegangan disamping kotak teks.

8) Anda dapat menggabungkan berbagai efek untuk memodifikasi teks Anda.

7. MEMECAH TEKS MENJADI BAGIAN-BAGIAN TERSENDIRI
Untuk memecah teks, menjadi bagian-bagian tersendiri dapat dilakukan
dengan berbagai cara :

1) Klik Arrow tool pada toolbox. Pilih blok teks yang akan dipecah. Setelah
blok teks terpilih, klik Modify Break Apart untuk memecah huruf-huruf ke
dalam blok teks tersendiri. Blok teks akan diletakkan pada posisi yang sama
dengan posisi asalnya.

2) Pilih kembali Modify Break Apart untuk menjadikan setiap huruf sebagai
artwork yang dapat dimodifikasi.

3) Untuk memodifikasi setiap huruf yang ada dapat dilakukan dengan Arrow
tool atau Free Transform tool.

Dengan menggabungkan teknik-teknik modifikasi teks, Anda akan dapat
menemukan efek yang sangat bagus.
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BAB Il
BEKERJA DENGAN LAYER

1. Menambahkan Layer Baru

Setiap kali kita membuka dokumen baru Flash, maka otomatis akan
terbentuk sebuah layer yang diberi nama Layer 1. Bila Anda menambahkan
sebuah layer lagi, maka layer tersebut akan diberi nama Layer 2 dan diletakkan di
atas layer pertama. Demikian seterusnya.

Membuat Layer Baru
Jumlah layer yang dapat dibuat tidak terbatas bergantung pada besar memori
komputer. Layer tidak menambah ukuran file. Untuk menambah layer lakukan :

1) Klik simbol “Insert Layer” £ |

2) Atau juga bisa memilih menu Insert > Layer.

3) Setelah menambah layer, maka layer baru akan muncul tepat di atas layer
yang sekarang sedang aktif.

Informasi Layer
Berikut ini informasi dari tampilan layer pada timeline :

1. Icon “mata”l | untuk menampilkan dan menyembunyikan semua objek
yang ada di stage pada layer tersebut.

2. lIcon “kunci” = untuk membuka dan mengunci objek yang ada di stage
pada layer tersebut agar tidak dapat diedit secara sengaja maupun tidak
sengaja.

3. lIcon “kotak” O untuk menampilkan objek di stage dalam gambaran secara
online, bukan dalam keadaan gambar yang sebenarnya. Ini berguna bila obyek
tersebut sangat besar sehingga memberatkan kerja komputer.

Mengedit Layer

Mengubah urutan layer :

1) Klik nama layer untuk mengaktifkan layer.

2) Seret nama layer tersebut ke posisi urutan yang diinginkan.

Mengubah nama layer :
1) KIlik dua kali nama layer, kemudian ketik nama layer yang diinginkan.

Duplikasi layer :
1) Klik nama layer yang ingin diduplikasi.
2) Pilih menu Edit > Copy Frames.

3) Buat layer baru dengan mengklik simbol “Insert Layer” ) .
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4) Klik nama layer yang baru tersebut kemudian pilih menu Edit - Paste
Frames.

5. MENGUBAH URUTAN LAYER
Urutan layer dapat diubah dengan cara sebagai berikut :
1) KiIik Layer yang ingin dipindah.
2) Drag layer ke urutan yang diinginkan, baik ke atas atau ke bawah.

| =a0
P Laver 4 FF L) A

O
( Layer 3 DO |
Layer 2 < « o N
(2 Layer 1 =)

24l i
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BAB IV
ANIMASI

Pada pembahasan kali ini kita akan mempelajari teknik-teknik animasi seperti
mengubah ukuran objek, memutar, mengubah warna, fade in-out, dan efek morphing.

1. Keyframe
Keyframe adalah sebuah frame yang telah didefinisikan sebelumnya dan
merupakan frame kunci yang menentukan perubahan pada animasi. Jika anda
membuat frameby-
frame animation, setiap frame adalah keyframe yang kita buat sendiri
secara manual. Pada tweened animation, keyframe merupakan salah satu frame
penting sehingga pembuatan animasi dapat dilakukan otomatis oleh Flash.

2. Menciptakan Keyframe
Untuk menciptakan keyframe pada suatu frame di timeline, lakukan salah
satu dari hal berikut :
1) Pilih sebuah frame pada timeline kemudian pilih Insert > Keyframe.
2) Letakkan kursor pada sebuah frame di timeline kemudian klik kanan dan pilih
Insert Keyframe.

3. MENGATUR FRAME RATE
Frame Rate adalah kecepatan suatu animasi dimainkan dalam frame per
detik (fps). Standar kecepatan suatu film adalah 24 fps, sedangkan pada aplikasi
web seperti Quick Time dan AVI movies pada umumnya mempunyai kecepatan
12 fps. Biasanya kecepatan 12 fps ini akan memberikan hasil terbaik di web.
Untuk mengubah frame rate lakukan : Klik menu Modify - Document,
dan ubahlah nilai fps pada tag frame rate.

Title:

Description:

Dimensions: | Z=00od (width)  x 400 px :(height)

Match: ) Printer (® Default
Background color: )
Frame rate: | 12 fps
Ruler units: | Pixels v
Make Default [ OK ] [ Cancel ]
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4. Membaca Timeline

Flash membedakan representasi tipe animasi dalam timeline sebagai berikut :

1) Motion tween diindikasikan sebagai sebuah lingkaran hitam pada keyframe
awal, dilanjutkan dengan anak panah menuju keyframe akhir dengan latar
belakang biru terang.

2) Shape tween diindikasikan sama seperti motion tween, tetapi berlatar
belakang hijau terang.

3) Garis putus-putus menandakan tween animasi belum lengkap, misalnya isi
dari keyframe akhir belum ditentukan.

4) Sebuah keyframe diindikasikan sebagai sebuah lingkaran hitam. Frame yang
berlatar belakang abu-abu lembut yang berada setelah sebuah keyframe
menunjukkan bahwa frame-frame ini mempunyai isi yang sama sampai
diakhiri dengan sebuah persegi kosong.

5) Huruf a kecil mengindikasikan bahwa frame tersebut telah ditetapkan sebagai
e action dengan action panel

6) Sebuah bendera (flag) merah mengindikasikan bahwa frame tersebut
mengandung label atau komentar.

7) Jangkar (anchor) emas mengindikasikan frame tersebut sebagai named
anchor.

Ada dua cara teknik animasi di Flash, yaitu tweened animation (Motion
Tween dan Shape Tween) dan Frame-by-frame animation. Tweened
animation anda tinggal menentukan posisi frame awal dan akhir, kemudian flash
akan mengerjakan animasi frame-frame sisanya yang berada di antara posisi awal
dan akhir tersebut. Frame-by-frame animation membuat gambar yang berbeda di
setiap frame.

Membuat Motion Tween

Prinsip kerja dari motion tween adalah benda dapat bergerak dari titik A ke
titik B. Kita tinggal mengisi frame pertama (titik A) dan pada tempat
pemberhentikan (titik B), selanjutnya flash sendiri yang secara otomatis akan
menangani frame-frame lainnya.

Membuat Animasi Bentuk

Langkah-langkah untuk melakukan animasi bentuk adalah sbb:

1) Kilik Rectangle tool, lalu gambarlah bujur sangkar di bagian kiri layar.

2) Klik menu Edit -  Select All untuk memilih bujur sangkar.

3) Klik menu Insert - Convert to Symbol, akan muncul kotak dialognya,
pilihlah pada bagian Behavior : Graphic.

4) KIlik pada frame 20 di timeline, kemudian klik menu Insert > Keyframe.

5) Posisi masih pada frame 20, klik Arrow tool, kemudian pilih bujur sangkar
dan pindahkan ke bagian kanan layar.
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6) Kilik pada frame 1 untuk kembali ke frame 1, kemudian lihat ke bawah layar
pada Properties. Pilihlah bagian Tween: pilih Motion.

7) Klik menu Control - Test Movie untuk menjalankan animasi (Control
- Play/hasil test ada pada scene). Untuk meyimpan hasil latihan, klik
menu File > Save As, kemudian beri nama filenya.

8) Untuk menghentikan test tekan Ctrl+W.

Keterangan :

Langkah pertama adalah menggambar lingkaran dengan Rectangle tool.

Dengan perintah Select All, kita memilih semua bujur sangkar baik bidang

maupun pinggirnya karena ketika Anda menggambar, secara default Flash akan

memberi dua unsur objek yaitu bidang dan pinggirnya.

Sebelum bisa dianimasikan, bujur sangkar harus diubah menjadi simbol dengan

perintah Convert to Symbol.

Symbol adalah objek Flash. Di dalam simbol inilah objek animasi dibuat. Ada

tiga jenis symbol.

1) Movie Clip, untuk membuat rangkaian animasi objek di dalamnya.

2) Button, untuk membuat tombol interaktif.

3) Graphic, untuk membuat animasi diam yang siap untuk dianimasikan pada
layar.

Objek yang diubah ke simbol ditandai dengan tanda plus di tengah objek. Apabila

suatu objek sudah dikonversi ke simbol, akan masuk ke dalam daftar Library.

Library adalah tempat penyimpanan objek-objek dalam Flash yang sudah

dikonversi ke simbol dan objek-objek yang diimpor dari tempat lain. Dengan

adanya Library, objek-objek dapat terorganisasi dengan baik.

Membuat Animasi Putar

Langkah-langkah :

1) Klik Oval tool, kemudian gambarlah bola dengan warna gradasi dan
pencahayaannya dari atas Kiri.

2) Pilih bola yang sudah digradasi, kemudian klik menu Insert - New
Symbol pilih Graphic.

3) KIlik pada frame 30, lalu klik mouse sebelah kanan pilih Keyframe.

4) Klik Arrow tool, kemudian pilih bola gradasi dan pindahkan ke bawah kanan
layar

5) Klik pada frame 1 untuk kembali ke frame 1, lalu pada Properties pilihlah
bagian Tween: Motion, isikan pada Ease: -100(in) dan Rotate:CW dengan
nilai 1 times.

6) Terakhir tambahkan suara. Klik menu Windows - Comman Libraries
- Sound, akan muncul pilihan suara.

7) Seret salah satu sound, misalnya Beam Scan ke objek bola gradasi di frame 1.
Jalankan animasi.

Keterangan :
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e Latihan ini masih menggunakan motion tween, tapi dengan sedikit modifikasi
pada bagian properties-nya untuk menghasilkan animasi berputar, seperti : Ease
ada dua jenis yaitu:

1) Ease Out (100) berfungsi untuk membuat animasi dimulai dengan cepat dan
diakhiri dengan lambat.

2) Ease In (-100) berfungsi untuk membuat animasi dimulai dengan lambat dan
diakhiri dengan cepat.

e Rotate ada tiga jenis :

1) Auto, berfungsi untuk memutar objek sekali pada arah yang ditentukan oleh
motion.

2) CW (Clockwise), berfungsi untuk memutar objek dengan arah sesuai dengan
jarum jam.

3) CCW (Counterclockwise), berfungsi untuk memutar objek dengan arah yang
berlawanan dengan jarum jam.

e Penggunaan suara menambah daya tarik animasi. Suara dapat diambil dalam
Flash dalam Comman Library Sound. Jika ingin mengambil suara dari koleksi
Anda sendiri, maka harus diimpor terlebih dahulu ke dalam library. Klik menu
File = Import, pilih file suara yang dimiliki. Jenis suara yang diperbolehkan
dalam Flash adalah : MP3, WAV, SUN AU, AIFF.

8. Membuat Animasi Warna

Langkah-langkah :

1) KIlik Text tool, lalu tulislah kalimat ‘ADOBE FLASH’, melalui Properties
aturlah jenis hurufnya Arial Black, ukuran 30, dan warnanya hitam.

2) KIlik Arrow tool, Pilih teks, Klik menu Insert - Concert to Symbol, lalu
ubahlah menjadi simbol Graphic.

3) KIlik pada frame 20 lalu masukkan Keyframe, lakukan hal yang sama pada
frame 40.

4) Kilik frame 20 lagi untuk kembali ke frame 20, lalu pilih teks menggunakan
Arrow tool. Pada Properties, pilihlah pada bagian Color:Alpha dengan nilai
0%.

5) Klik pada frame 40, lalu pilih teks. Pada Properties, pilihlah pada bagian
Color: Tint dengan warna Hijau dan nilai 100%.

6) Klik pada frame 1, lalu pada Properties pilihnlah bagian Tween:Motion.
Lakukan hal yang sama pada frame 20. Jalankan animasi.

Keterangan :

e Efek warna Alpha pada suatu objek akan memberi efek mumudar, misal tulisan
ADOBE FLASH, karena diberi efek alpha dengan nilai 0%, maka tulisan tersebut
perlahan-lahan akan menghilang.

e Efek Tint atau warna tint pada suatu objek akan memberi efek perubahan warna,
misalnya tulisan Adobe Flash, yang semula berwarna hitam akan berubah menjadi
hijau.

9. Membuat Shape Tween
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Animasi shape tween digunakan untuk mengubah bentuk suatu objek
menjadi bentuk yang sama sekali lain dari aslinya. Misalnya jika kita ingin
mengubah bentuk dari huruf Z menjadi huruf A.

10. Membuat Animasi Bentuk
Sebagai latihan kita akan membuat objek kotak menjadi teks kotak.
Langkah-langkah :
1) KIlik Rectangle tool, dan buatlah sebuah kotak dilayar.
2) Kilik pada frame 30, lalu klik menu Insert - Blank Keyframe.
3) Masih di frame 30, klik Teks tool, lalu tuliskan kalimat ‘KOTAK”.
4) Pada tulisan, lalu klik menu Modify - Break Apart sebanyak dua kali.
5) KIlik pada frame 1 untuk kembali ke frame 1, lalu pada properties pilihlah
bagian Tween : Shape. Jalankan animasi dan lihat hasilnya.

11. Frame-By-Frame Animation
Frame-by-frame animation ini seperti pekerjaan manual yang dilakukan oleh
manusia bila membuat film kartun dan penggunaan sangat cocok untuk animasi
yang rumit. Cara kerja Flash tidak berbeda seperti itu. Kita menggambar frame
per frame di stage, setelah itu baru dijalankan. Animasi jenis ini mempunyai
ukuran file jauh lebih besar dibandingkan tweened animation.

12. Membuat Frame-By-Frame Animation
Definiskan setiap frame sebagai keyframe dan ciptakan gambar yang
berbeda pada setiap frame. Bila kita menciptakan sebuah keyframe baru, maka isi
dari keyframe itu secara otomatis akan sama dengan keyframe yang
mendahuluinya sehingga selain bisa mengganti frame tadi dengan gambar yang
lain kita juga dapat memodifikasi gambar sebelumnya untuk membuat suatu
perubahan.

1) Klik sebuah layer untuk memilih layer tersebut dan kemudian klik sebuah
frame pada layer tersebut di mana anda ingin animasi di mulai.

2) Jika frame pertama tadi belum berupa keyframe, pilih menu Insert
- Keyframe pada menu bar untuk membuatnya.

3) Ciptakan gambar animasi anda. Anda bisa menggunakan Drawing Tool pada
toolbox atau mengimport sebuah file.

4) Klik frame berikutnya pada layer yang sama kemudian pilih Insert
- Keyframe.

5) Karena isi keyframe baru ini sama dengan isi keyframe sebelumnya, maka
anda dapat memodifikasi gambar itu atau menggantinya dengan gambar yang
baru.

6) Untuk menyelesaikan animasi anda, ulangi langkah 4 dan 5 sampai animasi
anda menjadi komplit.
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BAB V
MOVIE CLIP

Movie Clip adalah sebuah symbol yang menampung animasi Flash atau disebut

juga sebagai mini movie. Movie Clip akan tersimpan di dalam jendela library sehingga
dapat dipergunakan berulang kali. Movie Clip dapat dijalankan di dalam movie utama
hanya dengan menggunakan satu buah frame.

Membuat Movie Clip

Berikut langkah membuat Movie Clip:

1.
2.

3.

o oA

Siapkan lembar kerja default.

Selanjutnya kita akan membuat animasi putar pada objek bintang yang diletakkan
di dalam Movie Clip.

Klik menu Insert » pilih New Symbol atau tekan Ctrl + F8 sehingga akan
ditampilkan kotak dialog Create New Symbol seperti pada gambar di bawah:

Create New Symbol
Name: | 8
Type: () Mavie clip

O Eutbon

() araphic

Ketikkan ““ Bintang” pada kotak Name, untuk memberi nama Movie Clip.

Pilih Movie Clip pada pilihan Type.

Akhiri dengan OK sehingga secara otomatis, Anda akan aktif di dalam tampilan
lembar kerja Movie Clip “Bintang”.

Movie clip “ Bintang “

Lntitled-1% * - g X
| Timelne || &2 | E &4 | w0 v
& 50 1 10 15 20 Fi 30 5 =
[ v O »
W

e @ ([ B&D W ]t 2ok | 00s € >
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7. Selanjutnya membuat animasi pada Movie Clip “Bintang”.

8. Didalam layer 1, buat objek bintang pada frame 1 seperti pada gambar di bawah:

Untitled-1%*

- 8 X
| Timeline | %Scenel %v éjv 1009 Evs
i & 9 0O c 10 15 20 2 20 £ =

[ Vi O ~
=
] i || ¢ Flw B ] 1 [2ors [ 0o € ES
)
o
<

9. Kiik kanan pada frame 20, pilih Insert Keyframe.

10. Klik kanan diantara frame 1 sampai dengan 20, pilih Create Motion Tween.

11. Ubah pilihan Rotate dalam jendela properties menjadi CW. Pilihan

CwW
merupakan perputaran searah jarum jam.

§ ¥ Properties  Filkers | Parameters

Ii Bretie Tween: | Motion | [¥]5cale

=Frame Label= Ease: | 0O w

Label bvpe: Raotate: | Adto A

[Jorient to path Sync Snap

Rotate CW

12. Animasi sudah dibuat, selanjutnya kembali ke lembar kerja movie utama. Untuk
kembali ke movie utama, perhatikan gambar dibawah:

Kembali ke Movie utama

[ Unttec-1+ = = &
| Timeline | P % %, ‘@], 1003 M
&G0 3 in 15 ﬁ 5 0 £ i,
B
17|Modul Flash
'
el i [t BT T [ 2o |120fs | 16 € »




13. Selanjutnya memasukkan symbol Movie Clip “Bintang” dari library ke dalam

movie utama (layer 1 — frame 1).
14. Tekan F11 untuk menampilkan jendela library.

15. Geser Movie Clip “Bintang” dari jendela library ke dalam lembar kerja movie

utama. Perhatikan gambar di bawah:

i Color
Unitled-1% =x ||

= ii ¥ Library - Untitled-1

| Timeline | %S[EI‘IE[ %. @_ jLoos]

Untitled-1 v | Ea

~

< >

mEmA e ~

H &80 5 0 15 20 Fi3 Eil 35 28 p—
2 7 O
4] @ (| b @D B E o [0k |0 € »
Mame |Typa £
_ - Bintang Mavie 01
-
_ - - I@ Tween 1 Graphic
- [5] Tweenz Graphic
¥

16. Selanjutnya perhatikan tampilan timeline layer 1 pada movie utama seperti pada

gambar di bawah. Di dalam frame 1, berisi Movie Clip “Bintang”

Unkitied-1* 8%
|m| % Scene 1 %v @v 0036 -
&340 3 10 15 20 = 30 S =

[J i ~
A
i E] || 4] ®w W [eers | 0 g >

17. Jalankan animasi dan perhatikan hasilnya. Animasi Bintang akan
meskipun hanya menempati satu buah frame.
18. Simpan file Anda dengan nama Movie Clip.fla.

dijalankan
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BAB VI
BUTTON

Symbol Button dapat digunakan sebagai tombol navigasi dalam sebuah animasi
atau movie yang dihasilkan program Flash Pro 8. Di dalam sebuah symbol Button
terdapat empat bagian dengan penjelasan sebagai berikut:

e Up : merupakan tampilan awal tombol pada saat tidak disentuh oleh pointer
mouse

e Over :merupakan tampilan pada saat pointer mouse menyentuh atau berada di
atas simbol

e Down : merupakan tampilan pada saat tombol di klik dengan mouse

e Hit : merupakan area klik pada tombol

Membuat Symbol Button
Semua objek yang dibuat di dalam Flash Pro 8 dapat digunakan sebagai symbol
Button. Berikut kita akan membuat symbol Button dari sebuah objek teks:
1. Siapkan lembar kerja baru dengan tampilan default.
2. Klik menu Insert » New Symbol sehingga tampil kotak dialog Create New
Symbol seperti pada gambar di bawah:

Create New Symbol E|
Mame: | Tambol
Type: () Movie dlip

@ Button
(O Graphic

Ketikkan “Tombol” untuk memberi nama symbol Button pada kotak Name.

Pilih Button pada pilihan Type dan diakhiri dengan OK

Secara otomatis, anda akan aktif didalam tampilan lembar kerja symbol Button
Tombol. Perhatikan tampilan timeline seperti pada gambar di bawah:

ok w

Untitled-1* -8x
Timeline || &5 |5 im & 4 o v
&g I:I||_L|U0uer [own] Hit | =
) 7 O || A
199|Modu g lash
4] ([} BE B Lt |zoks |0 € ?




6. Dalam timeline terdapat empat frame yaitu Up, Over, Down dan Hit.

7. Klik pada frame Up dan buat objek teks “Tombol” dengan warna Hitam.
Perhatikan gambar di bawah:

Untitled-1*

e | & | Y

&40 Crwer Dawn| Hit |=

=

¥ Laver 1 7

A

Tombol

8. Selanjutnya membuat tampilan Over pada tombol.

9. Kilik kanan frame Over P> pilih Insert Keyframe sehingga didalam frame Over
disisipkan keyframe dengan objek teks yang sama dengan frame Up.

10. Ubah warna teks pada frame over menjadi merah dan perbesar ukuran teks

sehingga pada saat pointer mouse berada diatas tombol, maka tombol akan
berubah warna merah dan berubah ukuran.

[

Urtitled-1*

(o | & | g o[ o
®580| l=

&

Crower| Hit

245 @ ||t Be B e [z [ <]

Tombo
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11. Klik kanan frame Down P pilih Insert Keyframe.

12. Ubah ukuran teks “Tombol” seperti pada frame Up dengan posisi teks yang sama
sehingga pada saat tombol diklik akan mengecil.

£ il

Untitled-1* - ax
Timeline | <3 % ([l_uj %_ @' 100% L
&0 |:|| Up [Ower Hit =
[ Vi | &
b

4] f || Blw wm s ofps | o= € ¥

Tombol

13. Untuk membuat frame Hit, klik kanan pada frame Hit » Insert Keyframe
sehingga isi dan frame Hit sama dengan frame Down. Frame Hit digunakan untuk
menentukan area klik pada tombol. Area klik pada tombol menyesuaikan dengan
bentuk dan ukuran tombol. Tampilan timeline tombol akan nampak seperti pada
gambar di bawah:

F ™
Untitled-1* -

Timeline | <3 % H}_“-‘] %v @v 100%. v

u 1]
x

B E] it D B o4 |of: |0 £ ?

14. Setelah selesai membuat tombol, klik Scene 1 untuk kembali ke lembar kerja
movie utama.

15. Selanjutnya menyisikan symbol Button dari library ke dalam lembar kerja movie
utama.
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16. Tekan F11 untuk menampilkan jendela Library. Klik nama symbol Button
“Tombol” dan geser ke dalam lembar kerja movie utama.

17. Jalankan animasi. Pada saat tombol ditunjuk, tombol berwarna hitam. Pada saat
pointer mouse berada diatas tombol, maka berubah menjadi warna merah dan
membesar, selanjutnya pada saat diklik maka tombol mengecil ke ukuran semula.

18. Catatan : Anda dapat membuat symbol Grapic atau Movie Clip pada masing-
masing frame Button sehingga tampilan tombol semakin menarik.
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BAB VII
ACTION SCRIPT

Action Script adalah suatu perintah yang menghasilkan suatu aksi atau gerakan
pada objek. Perintah Action Script digunakan untuk membuat animasi yang lebih
kompleks dan interaktif.

Fungsi Panel Action Script

Panel Action Script digunakan untuk memberikan perintah action pada sebuah
frame, objek tombol atau Movie Clip instance.

Langkah untuk membuka jendela Action adalah dengan menekan tombol F9
atau klik menu Windows P Actions. Gambar di bawah adalah bagian-bagian dari
jendela Action:

. __mmss=asas.: |
i w Actions - Frame

=

@

BctionScript 1.0 & 2.0 v |2 & Sy, Script Assist

Global Functions 1 |
Global Propetties
Operators

Staternents
ActionScript 2.0 Claszes
Compiler Directives
Constants

Types

Depracated E|
Drata Components

Cormponents
Screens

E} Index
| I—— |
B Current Selection o
b E' Layer 1 Frame 1 E| Layer 1:1 |ZH
% Scene 1 ¥ |line1of1, Colil

Tombol perintah yang dapat digunakan dalam jendela Action antara lain:
a. Add a New Item to the Script

Digunakan untuk memberi/menambah perintah Action Script <= .
Contoh:

1. KIlik frame atau objek yang akan di beri script.
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2. Klik tombol Add a New Item to the Script <= P Global Function
Timeline Control » Play

___________________==as |

it v Actions - Frame =,
|ActionSeript 10 824 v &= 8 & e  soiptAssst @
| Global Functions M| Timeling Contral 3 gotodndPlay  Eschgp
1A Global Functions
lobal Propertes Global Properties b Browser/Network b gotodndStop  Esctas
Operators ¥ Printing Functions M mextFrame  Escnf
Operators
Statements Statements b Miscellaneous Functions ¥ nextScene  Esctns
i ipt 2, 4 i i 4
Aclioniseript 2.0 Clgees Actml?Scnplt 2 D Classes Mathem‘lat|cal FunFt|0ns Esc+pl
ey B Compiler Directives ¥ Conversion Functions ¥ prevFrame  Escpf
ornpliel Directives
p Canstants b Movie Clip Contral b previcene  Esc4ps |
Constant
anstants Types b stop Esc+st
Types
N Deprecated 3 stopAllSounds Esctss
=
Cenieealed il Data Components »
Data Comnponents L] Components b
Components Screens b
Screens
@ Index
Ll
] [ & Current Selection A
B Layer 1: Frame 1 = EI Layer 1:1 |4
% Scene 1 ¥ line 1 of 1, Cal 1
b. Find

Digunakan untuk mencari dan mengganti kata atau karakter yang terdapat
pada perintah Action Script 2 .

c. Inserta Target Path
Digunakan untuk menyisipkan target atau sasaran yang akan di beri perintah
Action Script.
Contoh penggunaan tombol Insert a target path &
1. Buat gambar objek bola di layer dengan tombol Oval.
2. KIlik Arrow Tool dan pilih gambar objek Bola tersebut.
3. Tekan tombol F8 untuk mengubah objek. Bola menjadi objek Button.

Convert to Symbol

Marne: |Bola | I O ]
Type: (O Movie dip Reqistration: EEE
(%) Buttan

O i5raphic

4. Pada bagian Name, ketik Bola, pada Type, pilih Button kemudian tekan OK.
5. Kilik bagian Instance Name, Kemudian beri nama Bola.

£ % properties  Filkers | Parameters

‘{%} Bukton V| Instance of:  Bola

=Instance Mame:= | [5wa|:|... ] |Track as button V|
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Sk

Tekan tombol F9 untuk menampilkan jendela Action.

7. Klik tombol Add a new Item to the Script » Global Function » Movie
Clip Control » On, maka tampil perintah script seperti nampak pada gambar
di bawah.

¥ Actions - Button

EOE Gy E @ “§, Script Assist @

@) releaseCutside
@ rollowver

@ rollout

@ dragOver

@ dragOut

@ keyPress "<Left=" v

8. Klik dua kali perintah Press sehingga terbentuk perintah script berikut

¥ Actions - Button

®ROVERE

Un (pressa) |
z N

9. KIlik di belakang tanda kurung kurawal buka “{* kemudian tekan tombol
Enter untuk memberi jarak baris.

10. Klik tombol Add a new Item to the Script > Global Function » Movie
Clip Control P> StartDrag, sehingga terbentuk perintah script berikut:

w* Actions - Button
B OYERE

8 on [press)

startDragi() ;

11. Klik tombol Insert a target path maka tampil kotak dialog insert Target Path
seperti gambar di bawah:

Insert Target Path

| this | K

() Relative () Absoluke
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12. Klik nama Instance Objek yaitu bola yang berada di dalam kotak dialog
Insert Target Path kemudian tekan tombol OK, sehingga terbentuk perintah
script berikiit

¥ Actions - Button

\#.}QEBV;E('?BO.

1 on [press) {

& starchragithis) ;
3}

13. Klik dibelakang kurung kurawal yang bawah kemudian tekan Enter untuk
memberi jarak baris.

14. Klik tombol Plus P> Global Functions » Movie Clip Control » On.

15. Klik dua kali perintah release, sehingga terbentuk perintah script berikut:

¥ Actions - Button

w B ovE RE

16. Klik di belakang kurung kurawal yang atas kemudian tekan Enter untuk
memberi jarak baris.

17. Klik tombol Plus P> Action » Movie Clip Control P> stopDrag, agar objek
bola dapat digeser dan dilepaskan di posisi yang lain. Perintah script akan
terlihat seperti perintah berikut:

¥ Actions - Button
2P OVEEE

58 on ipress) |

startDrag(this):
kN

3 on (release)] {

! stoplrag(]:

5

18. Tekan tombol Ctrl + Enter untuk menguji perintah di atas.

d. Check Syntax
Digunakan untuk memeriksa apakah perintah Action Script yang dituliskan
tersebut benar atau tidak .
Contoh 1:
1) Tampilkan jendela Action dengan menekan F9.
2) Ketikkan perintah gotoAndPlay(1).
3) Tekan tombol Check Syntax, maka tampil komentar This script contains no
errors, berarti tidak ada kesalahan dalam penulisan script Anda.

Flash B 3
This script contains no errors.
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Contoh 2:

1) Tampilkan jendela Action dengan menekan F9.

2) Ketikkan perintah gotoAnStop(.

3) Tekan tombol Check Syntax, sehingga tampil komentar This script contains
errors, The errors encountered are listed in the Output Window, berarti
ada kesalahan dalam script Anda.

This scripk contains errors, The errors encountered are listed in the Output Panel,

e. Auto Format
Digunakan untuk mengatur format pada perintah Script yang telah

dimasukkan, sesuai dengan format yang telah diatur oleh program Flash £

f. Show Code Hint
Digunakan untuk menampilkan kode penunjuk & untuk membantu Anda
dalam menuliskan perintah yang benar.
Contoh:
Pada jendela Action, ketikkan rumus stop( maka tampil keterangan yang
menunjukkan bagaiman seharusnya rumus stop tersebut diketik.

stop (

_ . Rumus stop
stop 0); > yang benar

Jika keterangan tersebut tidak muncul tekan tombol Show Code Hint untuk
memunculkannya.

g. Debug Options
Digunakan untuk menampilkan atau menghapus tanda breakpoint #.. Klik
tombol Debug Options, maka muncul 3 perintah yaitu:
e Toggle Breakpoint, untuk menampilkan tanda breakpoint.
e Remove Breakpoint, untuk menghapus tanda breakpoint.
e RemoveAll Breakpoint, untuk menghapus semua tanda breakpoint

h. Script Assist
Peranti ini digunakan untuk mengolah perintah script tertentu sehingga

mempermudah Kita untuk mengatur parameter dari script tersebut " serint assist

goto : Go to the specified frame of the movie
(%) Go to and play (O Go to and skop
Scene: | <current scene=
Type: |Frame Mumber

Frame: |1

O z|RlEx

{E = }3 - ‘\ Script Assist

o8 on (release)] {

gotoAndPlay (1)

i
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BAB VIII
PUBLIKASI

Keistimewaan Flash yang dipublikasikan adalah dapat didesain untuk keperluan
presentasi pada sebuah animasi halaman Web. Perintah publish akan menyisipkan file
Flash Player (SWF) dan dokumen HTML ke dalam jendela browser.

Perintah Export Movie mengijinkan Anda membuat isi Flash yang dapat
disunting dalam aplikasi yang lain dan mengekspor sebuah movie langsung kedalam
format tunggal. Sebagai contoh, Anda dapat mengekspor movie seperti file Flash Player,
rangkaian image bitmap, frame tunggal atau file image, dengan berbagai variasi format,
termasuk GIF, JPEG, PNG, BMP, PICT, QuickTime, dan Avi.

Mempublikasikan Flash Movie
Untuk mempublikasikan Flash Movie pada Web, Anda dapat menggunakan
dua langkah proses. Pertama, siapkan semua file yang diperlukan untuk melengkapi
aplikasi Flash dengan Publish Settings. Kemudian konversikan file movie beserta
isinya dengan perintah Publish. Langkah dalam menentukan pilihan untuk file Flash
movie adalah:
1. Buat sebuah animasi sesuai dengan selera Anda dan simpan animasi tersebut
dengan nama: Design.fla pada folder Animasi.
2. Pilih menu File » Publish Settings, sehingga tampil kotak dialog Publish
Settings seperti pada gambar di bawah:

Publish Settings EJ

Curent profle: o) b +[=0

Formats | Flash | HTML

Type: File:

[¥Flash { swf) Untitled-1 . swf
HTML (bl Untitled-1.html
[[]1F Image (. gif) Unitled-1.gif
[[13PES Image (.ipa) Lintitled-1.jpg
[CIPmG Image {.png) Urtitled-1.png
[ windows Projector {.exe) | Untitled-1,exe

[[IMacintosh Projectar Urkitled-1.hgx

TTTTTTT

[ GuickTime {.mov) Untitled-1. maov

Use Default Mames

Publish ] l 0K ] [ Cancel

3. Pilih tipe yang ingin Anda hasilkan pada pilihan kotak periksa Type, yaitu: .swf,
.html, .gif dan lain sebagainya.
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Format HTML otomatis terpilih, karena file HTML dibutuhkan untuk
menampilkan Flash movie Anda ke dalam browser. Jika format yang dipilih
mempunyai sub perintah, maka akan ditampilkan tabulasi yang sejajar dengan
tabulasi HTML.

Pada bagian File, pilih salah satu perintah berikut:

e Gunakan nama file default yang sudah ada, jadi Anda tidak perlu mengetik nama
file baru.

e Hapus nama file default, kemudian masukkan nama file baru.

Anda dapat menentukan di mana Anda mempublikasikan file tersebut pada
lokasi yang berbeda. Sebagai contoh, jika Anda ingin menyimpan file SWF ke dalam
satu lokasi dan file HTML ke dalam lokasi yang lain). Dalam kotak teks, gunakan
backslash (\') untuk menyusun urutan penulisan directory, folder, dan file.

Sebagai contoh, D:\Folder\filenama.swf di mana D: adalah nama drive,
\Folder adalah nama folder, dan filename.swf adalah nama filenya.

Publish Settings 3
Current profile: | Default v @' + [ O
Formats | Flash | HTML
Type: File:
[#]Flash {.swf3 C:AFlashiAnimasil, swf @
HTML (. htral) Untitled-1. bl B
[ GIF Image {.qif) Untitled-1. gif (¥
[ IPEG Image (.jpg) Linkitled-1.jpg B
[ Pr Image {.prg) Untitled-1.prg @
Windows Projector { exe) | CiFlashianimasil, exe @
[ Macintosh Prajector Untitled-1.hagx @
[ QuickTirne: (. mov) Untitled-1, moy @
[ Use Defaulk Mames ]
Publish ] [ Ok l [ Cancel
Catatan:
e Untuk membuat sebuah file yang nberakhiran .exe, pilih pilihan Windows
Projector.

e Masukkan sebuah file baru, atau pilih Use Default Name agar setiap file
menggunakan nama file default.

e Tekan tombol Publish untuk menjalankan pilihan di atas dan klik OK untuk
menutup kotak dialog Publish Settings.
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